JCC LogMiner Loader Replication to JDBC Targets [Java Versions]

To use the JCC LogMiner Loader to replicate data from an Rdb database to a JDBC target, one must have a class IV JDBC driver that is certified to work with the target data store.  The JDBC driver contains the client JDBC methods used by the Loader to access the target JDBC server for data replication.  To use a JDBC driver on OpenVMS requires Java be installed on OpenVMS.  The earliest version of Java that supports the necessary methods for JDBC and the JCC LogMiner Loader is Java 1.4.2.  Some JDBC drivers require Java versions newer than 1.4.2.  Please check with the supplier of the JDBC driver for their minimum supported Java version.

The version of Java available on OpenVMS depends on the CPU architecture (VAX, Alpha or Itanium) and the installed version of OpenVMS.  Links to the HP site where you can download any of the various versions of Java on OpenVMS mentioned in this document are located in the resources section at the bottom of this document.

VAX

There is no version of Java available from HP that runs on OpenVMS VAX systems.  If you are running OpenVMS on a VAX, there are still options that will allow you to use the JCC LogMiner Loader to replicate your data to a JDBC data store.  Please contact JCC directly using the contact information at the top of this page to discuss the alternatives.

Alpha (a.k.a. AXP)

As of the writing of this document, the most recent version of Java for Alpha OpenVMS versions 8.2 or later is Java 5.0-8 (a.k.a. 1.5.0-8).

On Alpha OpenVMS 7.3-2, the most recent version of Java available is Java 5.0-3 (a.k.a. 1.5.0-3).

The earliest version of Alpha OpenVMS that supports Java 1.4.2 is Alpha OpenVMS 7.3-1.  The most recent patch level available that is supported on Alpha OpenVMS 7.3-1 is Java 1.4.2-4.

Note: The JCC LogMiner Loader has encountered issues with Java 1.4.2 when using the FASTVM and therefore only the CLASSIC VM is supported.

If you are running a version earlier than 7.3-1, there are still options that will allow you to use the JCC LogMiner Loader to replicate your data to a JDBC data store.  Please contact JCC directly using the contact information at the top of this page to discuss the alternatives.

Itanium (a.k.a. Integrity)

As of the writing of this document, the most recent version of Java for Itanium OpenVMS 8.3 or later is Java 6.0-6 (a.k.a. 1.6.0-6) and is only supported with the logical JAVA$FORCE_IEEE_FPSR defined as:

$ define JAVA$FORCE_IEEE_FPSR 1

Java 6.0-5 (a.k.a. 1.6.0-5) is supported with patch QXCM1001322821 by the JCC LogMiner Loader.  HP supplies this patch, so please contact HP support for availability.  Java 1.6.0-1 is also supported by the JCC LogMiner Loader.

As of the writing of this document, the most recent version of Java for Itanium OpenVMS 8.2-1 is Java 5.0-3 (a.k.a. 1.5.0-3).

Resources

The JCC LogMiner Loader can use either the J2SE™ Runtime Environment (JRE) or the J2SE™ Development Kit (JDK).

The most recent kits mentioned in the above sections are available from the HPE website at:

https://www.hpe.com/global/java/download/

The older kits mentioned in the above sections are available from the HPE website at:

https://www.hpe.com/global/java/archive_download/